(844) 627-8267
(844) 627-8267

Apple Finds Security Flaw That Could Allow Hackers To Exploit Devices, Users Urged To Install Updates | #hacking | #cybersecurity | #infosec | #comptia | #pentest | #hacker


Hackers ‘Actively Exploiting’ Apple Vulnerability, Users Advised To Install Security Updates

If you’re an Apple user, here’s a PSA for you to update your devices ASAP.

Source: Kevin Bhagat on Unsplash

The tech giant has discovered a software vulnerability affecting many of its products, and hackers have allegedly been actively exploiting it.

Apple has since released a security update to patch the vulnerability.

Users of its products have been urged to update their devices to the latest available versions to guard against these potential hacking attempts.

CSA advises Apple users to update devices due to security vulnerability

On 11 July, the Cyber Security Agency of Singapore (CSA) released an advisory informing Singaporeans that Apple has released new security updates to counter a zero-day vulnerability in its products.

Hewlett Packard Enterprise describes a zero-day vulnerability as “an undiscovered flaw in an application or operating system, a gap in security for which there is no [defence] or patch because the software maker does not know it exists”.

On its website, Apple reassured that its iOS 16.5.1 (a) and iPasOS 16.5.1 (a) updates would resolve WebKit issues, which previously caused devices to be “actively exploited”.

WebKit is the web browser engine used by Safari, Mail, App Store, and many other apps supported by Apple devices.

Source: Sirisvisual on Unsplash

CSA noted that hackers could run commands or codes in devices by “processing maliciously crafted web content” if successful in their hacking attempts.

This zero-day vulnerability’s impacts are far-reaching, affecting a suite of Apple products like iPhones, iPads, iPods, and Macs.

They include:

  • All iPhone 6s models
  • All iPhone 7 models
  • 1st generation iPhone SE
  • iPhone 8 and later
  • 5th generation iPad and later
  • 3rd generation iPad Air and later
  • iPad Air 2
  • 4th generation iPad mini and later
  • All iPad Pro models
  • 7th generation iPod Touch
  • Macs running on macOS Big Sur, Monterey, and Ventura

Some updates to also resolve website display issues

In its advisory, CSA advised Apple users to update their products to the latest versions immediately to protect themselves against the vulnerabilities.

These security updates come in the form of Rapid Security Responses, which Apple has been rolling out since 10 July.

For more information on the device-specific updates, users can refer to the Apple website.

Apple additionally announced the release of iOS 16.5.1 (c) and iPadOS 16.5.1 (c) on 12 July.

The two updates are set to mitigate issues some users faced with website display following their previous updates.

So, if you’re an Apple user, make sure to update your devices as soon as you can.

Alternatively, you can consider enabling automatic software updates on your devices to save the hassle in the future.

You can do so by heading to your device’s Settings > General > Software Updates > Enable Automatic Updates.

Have news you must share? Get in touch with us via email at [email protected].

Featured image adapted from Thai Nguyen on Unsplash.

——————————————————–


Click Here For The Original Story From This Source.

National Cyber Security

FREE
VIEW