Got an early iPhone or iPad? Update now or turn it into a paperweight – Naked Security


If you own an Apple iPhone 5, iPhone 4s or one of the early iPads with cellular connectivity, your device is about to be turned into a vintage technology paperweight by the GPS rollover problem that we wrote about in April.

Before we explain why, we should say it is possible to avoid this fate by updating your device to iOS version 10.3.4 (iPhone 5) or version 9.3.6 (iPhone 4 and iPads).

But there’s one critical detail – you must apply this update before 12:00 a.m. UTC on 3 November.

If you don’t follow this advice, the iPhone will, according to Apple, no longer be able to…

Maintain accurate GPS location and to continue to use functions that rely on correct date and time including App Store, iCloud, email, and web browsing.

So, losing the GPS stops the time and date being set, which immediately causes internet synchronisation problems affecting services that need to connect to remote servers.

In addition to the iPhone 5 and 4s, the iPads affected are the cellular-enabled iPad mini, iPad 2, and the third-generation iPad.

You can read the iPhone 5-specific warning or the one that includes the iPhone 4s if you want to confirm the worst in more detail.