Info@NationalCyberSecurity
Info@NationalCyberSecurity

HHS-HC3 calls for immediate hospital action to protect against ‘Citrix Bleed’ vulnerability and ransomware threat | #hacking | #cybersecurity | #infosec | #comptia | #pentest | #ransomware


The Department of Health and Human Services’ Health Sector Cybersecurity Coordination Center is urging hospitals and other critical infrastructure to take immediate action to patch and harden network systems to protect against a significant ransomware threat, the “Citrix Bleed” vulnerability. The vulnerability is exploited by ransomware gangs like LockBit 3.0 because it allows cyberthreat actors to bypass password requirements and multifactor authentication measures.

“This urgent warning by HC3 signifies the seriousness of the Citrix Bleed vulnerability and the urgent need to deploy the existing Citrix patches and upgrades to secure our systems,” said John Riggi, AHA’s national advisor for cybersecurity and risk. “This situation also demonstrates the aggressiveness by which foreign ransomware gangs, primarily Russian-speaking groups, continue to target hospitals and health systems. Ransomware attacks disrupt and delay health care delivery, placing patient lives in danger. We must remain vigilant and harden our cyber defenses, as there is no doubt that cyber criminals will continue to target the field, especially during the holiday season.”

For more information on this or other cyber and risk issues, contact Riggi at [email protected]. For the latest cyber and risk threat information and resources, visit www.aha.org/cybersecurity.

——————————————————–


Click Here For The Original Source.

National Cyber Security

FREE
VIEW